SM AP Version 7.06 Update Note
March 1, 2024

SMAP Version 7.06 includes following new features:

Liquefaction Analysis with PM4Sand

SMAP-2D and SMAP-3D include Example Problem VP34,

The main objective of this example is to verify PM4Sand model implemented in

SMAP-2D /3D under the plane strain condition. The PM4Sand (Boulanger and Ziotopoulou, 2017)

is the effective stress material model which is calibrated in finite difference program FLAC 8.0
(Itasca 2016) for the plane strain condition.

Following graph shows liquefied zones in the free field analysis compared with FLAC.
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Response Analysis Menu

SMAP-2D and SMAP-3D add Cudss and Modxy to Response Analysis Menu:
Convert Changing format of input earthquake acceleration data

Spectra Constructing response spectra from acceleration history

Shake 91  Solving 1D seismic response by frequency domain analysis

Srap 1D  Solving 1D seismic response by modal analysis

Quad 4M  Solving 2D seismic response by finite element analysis

Nonsap Solving static and dynamic response of nonlinear systems
State Plotting stress state on p-q space and octahedral plane
Cudss Solving stress-strain response at a single point for PM4Sand

DM_DSS  Drained Monotonic Direct Simple Shear

DM PSC Drained Monotonic Plane Strain Compression
UM_DSS  Undrained Monotonic Direct Simple Shear
DC DSS  Drained Cyclic Direct Simple Shear

UC DSS  Undrained Cyclic Direct Simple Shear

Modxy Modifying each XY data curve separately for PLOT-XY
All examples enclosed in the directory C: \ Smap \ Response

Modifying Each XY Curve
PLOT-XY includes Modify XY window which allows modification of each curve.

Maodify XY Data

Modify

Hrmin ’07 Hmax ’W
Hadd ,07 “add ,07
Hrnult ’W Ymul  [1.0000

For ¥ »= ¥min and ¥ <= Xmax
MNew ¥ = [X+xadd] * Xmult
MNew % = [¥+Yadd] * ¥mult

0Ok | Cancel




SM AP Version 7.05 Update Note
April 1, 2023

SMAP Version 7.05 includes following new features:

Beam Modal Analysis

SMAP-2D includes Example Problem VP31.

This example solves dynamic response of a simply supported beam subjected to
a concentrated step load at mid span by Modal Superposition Method.

First Mode (w = 1.358 rad/s) 0.49076
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0.42532
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Second Mode (w = 5.360 rad/s) 046514
0.40325
0.34135
0.27946
0.21757
0.15568
0.093790
0.031899
-0.029992
-0.091883
015377
021567
-0.27736
-0,33945
040134
-0.46323

Third Mode (w = 11.774 rad/s) 0.47506
0.41394
0.35181
0.280969
0.22757
0.16545
0.10333
0.041205
-0.020917
-0.083039
0.14515
-0.20728
-0,26840
-0.33153
-0,39365
-0.45577



2. Plate Modal Analysis
SMAP-3D includes Example Problem VP31.
This example solves dynamic response of a simply supported rectangular plate
subjected to a concentrated step load at center by Modal Superposition Method.

First Mode (w = 26.544 rad/s)
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Second Mode (w = 91.729 rad/s)

Third Mode (w = 172.992 rad/s)
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Seismic Response Analysis

SMAP-2D and SMAP-3D include Example Problem VP32.

This example solves free-field seismic response of the linearly viscous elastic soil profile
subjected to 1989 Diamond Heights earthquake excitation from the bedrock.
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Silo Lining Analysis

SMAP-S2 includes Example Problem VP17.

SMAP-2D and SMAP-3D include Example Problem VP33,

This example solves lining stresses developed in underground silo subjected to
residual water pressure. This silo structure in Gyeongju, South Korea, was constructed

to store the low-and-intermediate-level radioactive waste.

SMAP-3D model consists of 65,598 continuum, 792 joint, 1,584 shell elements and
71,867 nodes. It takes about 5 hours of run time in the following personal computer:
64 Bit Windows 11, 8 Core 17-11700F CPU, 16 GB of DDR4 Ram.

-

Storage Wall Lining Inner Hoop Stress along C-D  Subjected to Residual Water Pressure ” Rebar Meridian Stress along C-D Subjectedto Residual Water Pressure.

InnerHoop Stress (MPa)
Outer Rebar Meridian Stress (MPa)




5. SDOF System To Ground Acceleration
Example problem SMAP-2D (VP28) and SMAP-3D (VP27) now include viscous dampers.

SMAP results are almost identical to the exact solutions.
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Converting PLOT-XY to EXCEL

PLOT-XY is the post processing program showing SMAP results in the form of XY graph
with file extension .Lin. The guideline illustrates step-by-step procedure for converting
PLOT-XY to EXCEL. Refer to ( Converting PLOT-XY to EXCEL.pdf) in the directory
SmapS2/2D/3D > Example > XY _Graph
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When running PLOT-XY, minimum and maximum y values are saved in the directory
Current Working Directory \ Temp \ Plot XY Min_Max.dat



Plotting Stress States

Generally, the stress state at a point can be represented as shown in Figure (a) in the triaxial
principal stress space in terms of (0, ,0,,0;)or (p, q,0). Such three dimensional stress
plot can be decoupled to hydrostatic (p , q ) in Figure (b) and octahedral plane (0, q ) in Figure
(c), Recently, alternate octahedral plane ( 0, q ) in Figure (d), which is very simple to use, is
proposed in the reference; Numerical Parametric Studies on the Stress Distribution in Rocks

around Underground Silo, Feb. 2022, Applied Sciences 12(3) 1613.

Principal Stress Space (P, d,8) or (61,62,03)

Hydrostatic Plane (P . )

(a) ®
o1 Octahedral Plane
S,=0,-p- 5 N Space Diagonal
1
J, = 2 SU SiJ q
Failure Surface
1
R R Q-
q=,3J, =4y/3/2 ¢q e
- de
q-= 1/? Toct Failure Surface
p-yJ3p > Os
p
p
J
Lode Angle 8 = 1 Sin " [— 27 _3)
3 2 q
G2
Octahedral Plane (9,4 ) Alternate Octahedral Plane (6,9 )
(c) @
qQ
01
Failure Surface P%r; §he)ar
=0 Failure Surface
=
2
2 a
g de g
3 - &
] 5] el
Oz Os = @ ]
E| = E
k=] = =]
1 27 4 = - a
LodeAngle 8 = — Sin ' | - 2= =2 - ! 3]
3 2 q° 30° 0’ 0 30°

SMAP provides stress state plots of both hydrostatic plane ( p, q) in Figure (b) and
alternate octahedral plane ( 0, q ) in Figure (d) for the given input stress tensor.

Two examples are given in the directory: c:\Smap\Response\State\
Smap2d > Run > Response Analysis > State

EX-1: STATE inp.dat,
EX-2: EX-2.dat,

and then
Refer to

Smap2d > Run > Smap > Execute
Smap2d > Plot > Result > Plot 2d

c: \ Smap \ Response \ State \ Plotting Stress State.pdf



Plotting Response Spectra
Response spectra are plots of the maximum response of the single degree system over a range of
its natural period and selected values of damping for the given ground acceleration time history.

Response spectra provide characteristics of the ground motion and its effects on the single degree
of freedom structure.

SPECTRA is the modified version of program originally written by D. B. McCallen in 1991,
Lawrence National Laboratory, University of California, Livermore, for response spectra
generation.

SPECTRA computes following response spectra for the given acceleration time history.

e Accel Vs Freq.Lin Absolute acceleration as a function of frequency (cps)
e Acc_Spectra.Lin Absolute acceleration as a function of period (sec)

e Vel Spectra.Lin Relative velocity as a function of period (sec)

e Disp_Spectra.Lin Relative displacement as a function of period (sec)

Referto  c¢:\ Smap \ Response \ Spectra \ Plotting Response Spectra.pdf
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Response Analysis Menu

SMAP-2D and SMAP-3D include following programs for seismic analyses:
Convert Changing format of input earthquake acceleration data

Spectra Constructing response spectra from acceleration history

Shake 91  Solving 1D seismic response by frequency domain analysis
Srap 1D  Solving 1D seismic response by finite element analysis

Quad 4M  Solving 2D seismic response by finite element analysis
Nonsap Solving static and dynamic response of nonlinear systems

State Plotting stress state on p-q space and octahedral plane

All examples enclosed in the directory C: \ Smap \ Response



SM AP Version 7.04 Update Note
April 1, 2021

SMAP Version 7.04 includes following new features:

Material Based Element Index Order Change

Element index orders can be modified using preprocessing program

ADDRGN based on Material Numbers.

Refer to Users Manual page 8-18 for ADDRGN-2D and 8-31 for ADDRGN-3D .
Example problem is included in the folder: ADD-2D/ADD-3D > Others > MOD-6

Shell Element Bottom Surface Color and Local X Axis

Shell element bottom surface can be shown as light yellow by following selections:
PLOT-3D > Plot > Mesh > Mesh Type > Visible Surface with Material Color

To see local axis, check Show Shell Local X Axis

Axis color and line type can be selected by following selections:

View > General > Shell Local X Axis on Element Top Surface > Select color

View > Displacement > Display Options > Line Type > Select Solid / Dash

Element Activity Data Generation

(NELI, -NEL2) in SMAP-S2/2D/3D Users Manual Card Group 8.2 generates

the same activity from NEL1+1 to NEL2. It also applies to material based activity.
Refer to Activity.pdf in Example > Smap > Activity

Element Surface Traction Generation

Element surface traction can be generated based on both material and element numbers.
(NEL1, -NEL2) generates the same surface traction from NEL1+1 to NEL2.

It also applies to material based surface traction.

Refer to Users Manual Card 5.7 for SMAP-2D/3D and Card 5.7 for SMAP-S2.

Refer to Element Load.pdf in Example > Smap > Load

PLOT-2D includes new Express Style menus which are rearranged so as to quickly
access most frequently used menu items in practice.
For Express Style, specify 0 in C:\Smap\Ct\Ctdata\MenuStyle_2D.dat

£ pLOT 2D E=REER™

‘File View Tile Entity Mouse-Snap Mesh Zoom Replot Select Copy State  Mext Close [x] ‘




6.

PLOT-XY includes new Express Style menus which are rearranged so as to quickly

access most frequently used menu items in practice.
For Express Style, specify 0 in C:\Smap\Ct\Ctdata\MenuStyle_XY.dat

B3 pLOT XY [E=RE
|Fi|e View Tile Edit Character  Zoom Replot Select Copy State Next Close [x] ‘

SMAP-T2 / T3 includes new verification example VP5 which is an infinitely long
plate subjected to sudden application of constant internal heat generating source.

LOAD-2D /3D includes new loading surface generation features based on
Node and Element Groups. Refer to SMAP-T2 / T3 load example EXS.



SM AP Version 7.03 Update Note
May 1, 2020

SMAP Version 7.03 includes following new features:

Two-way Reinforced Concrete Shell Element

SMAP-3D: Example Problem VP30
Two-way Reinforced Axisymmetric Shell Element
SMAP-S2: Example Problem VP16
SMAP-2D: Example Problem VP30

Load Vector Plot by PLOT-3D

SMAP-S2: LOAD-2D\1. Pressure\Running LOAD-2D.pdf
SMAP-2D: LOAD-2D\1. Pressure\Running LOAD-2D.pdf
SMAP-3D: LOAD-3D\1. Pressure\Running LOAD-3D.pdf

New Feature in Wedge Block Mesh Generation
PRESMAP-GP:  Example Problem EX11

Data Value Option on Contour Plot
PLOT-3D: Select View > General > Data Values

Axial, Shear and Rotational Joint Spring Element (*)

SMAP-S2: Example Problem VP15
SMAP-2D: Example Problem VP29
SMAP-3D: Example Problem VP28

Soil and Joint Spring Generation for Shield Tunnel (*)
NATM-2D: Example Problem MODEL2-1
TUNAPLUS: Users Manual Card Group 6.5 and 6.6

(*) Updated in Version 7.02



SMAP Version 7.00 Update Note
April 25, 2019

SMAP Version 7.0 integrates all SMAP programs in unified and consistent way
along with complete users manual. Trial Versions can be used for 30 days
without registration.

SMAP Version 7.0 includes following new features:

64 Bit Operating System
SMAP Solvers supporting Windows 64 Bit Operating System

Block Mesh Generator
3D CAD program specially designed to generate finite element meshes

PlotXY Generator
Graphical User Interface to generate or edit Time Histories of results

SMAP-T3
3D Heat Conduction finite element program with phase change
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